Backup Synology using RSync and RaspPI

In your video ( you provide an IP address of and connect to your Pi / Linux hard drive via the Hyperbackup module in Synology (it’s on 6.x DSM, but 7.x should work more or less the same). However I don’t know how you physically connected the pi / drive to the Synology, driving the standard IP address. Was it via the mentioned powered USB? Could it also work the same via a powered ethernet switch?

I used ethernet via router and used the Pi IP address from my router, and could not connect. Understanding how you connected / used the might solve my conundrum.

PS - huge fan of SpaceRex videos. Living in Denmark. Cheers

Sounds like I’m having the exact same issue. The video seems to imply that the Pi and NAS are 9n the same local network. Ive followed the video exactly and get stuck when in the rsync wizard
I put in the Pi’s ip, use synology as the username, 123456 as the password. But then I try to select a backup module, it says “No reponse from the destination server.”

I’ve tried a bunch of things from various sources, but cant seem to get past this.

@Will - any tips to help us get past the connectivity from Synology to Pi? It’s really unclear how you’ve connected and seems I’m not the only one stuck. Many thanks!

It’s a permission problem. The owner of the HyperBackup task on the NAS does not have permission to access the destination directory.

To get the planets to align, lets go back to the Pi and tweak a few things so the rsync daemon and the directory the rsync process are run by the same user, and that user has the same uid as the HyperBackup task owner on the NAS.

Create a group and user using the uid of the NAS HyperBackup task user. This is likely your uid.

sudo groupadd -r -g 1027 synology
sudo useradd -r -u 1027 -g 1027 -m -c "Synology HyperBackup role" -d /home/synology -s /bin/false synology

Reprotect the destination directory. Mine is /home/synology. YMMV

sudo chown -R synology:synology /home/synology

Tweak the rsyncd.conf file to run as this user.

Grant explicit permissions in /etc/rsyncd.conf.

uid = synology
gid = synology
use chroot = no
pid file = /var/run/

  path = /home/synology
  comment = Synology HyperBackup
  read only = false
  timeout = 300
  list = yes
  hosts allow = *
  auth users = synology
  secrets file = /etc/rsyncd.secrets

Restart the rsynd daemon to pick up the changes.

/etc/init.d/rsync restart

Cross your fingers that this recipe gets you closer!

@sk8rs_dad - many thanks for the tips. I am definitely going to work my way through this in the next few weeks (busy busy life right now) and I will come back to let you know if it worked. Really appreciate you pitching in / helping here. Cheers!

I got mine working finally. There were a few issues all combined, and each contributed to the overall issue:

  1. My NAS and Pi were on different subnets on myblocal network. Long story short, the Pi could see the NAS, but the NAS could not see the Pi. I will ultimately be using a Tailscale VPN, and the Tailscale IP will persist once I move offsite, I corrected this connecrion issue by using the Tailscale IP, even on my local network.

  2. The permissions were set wrong. I noticed that I could do a hyperbackup to a folder in my Pi’s user home directory, but not on the mounted HDD. SpaceRex mentions that after modifying the fstab file and mounting, you should redo the chmod 777… I had neglected to do this, and as soon as I changed permissions to 777 it started working again. The solution above may be the way to go (creating a new user/group), but I havent attempted it yet.

  3. Faulty USB power supply. The external HDD was going offline periodically. Each time I would have to remount it on the Pi, and sometimes the permissions would revert back, reintroducing the problem above. I stripped the HDD out of its case and put it in a powered USB HDD dock, and the issue went away.

All in all, it works now, even when I moved the Pi offsite. For a while there it just felt like I had to bite my tounge just right in order for the rsync to complete.

dear forum friends,
I followed William’s tutorial to install the rsync server on the raspberry pi. I managed to make a backup on my local network. However, I have installed tailscale and I am unable to reach the rsync server from the synology via the tailscale network. can someone please help me with this challenge?

Greetings sk8rs_dad,

Thanks for your inputs and sorry for my late reply. I had to start over from scratch completely as my thumb drive, the “hard drive” for my Pi, corrupted - strange. Anyway, between normal work and life I just didn’t have enough nights to fiddle more with this until now.

I have implemented everything you recommended. In the original video, Will notes that the “Server Name or IP Address” to use is, and that’s just what it is (so he states). That did not work for me, so I used the address from my network assigned to it which was 192.168…. and that almost got me there. The NAS sees the Pi because it finds the shared folder called “backup,” but I get this error:

I had already redone the chmod 777, but did it again for good measure (as noted in gamendorf’s reply). That didn’t really help, unfortunately.

I am left thinking perhaps the UID you use (1027) or the destination directory you note (/home/synology) are different on my end and I am not sure how to check that. Or maybe it’s something different, but I’m not much of a coder, especially in Pi code.

I really appreciate your help and hope you can give the nudge or two to get this one over the line with me.

My earlier post was a template, not a prescription.

Will’s video assumes the viewer understands basic networking. When he said the IP address was, he means on his network. Your devices will have different IP addresses that match your network.

Synology’s error message does not provide sufficient information to diagnose. My first guess would be that the owner of the backup task doesn’t match the owner of the backup directory.

If you can ssh into the NAS, run id and save your UID/GID information. Make sure at least the GID matches the backup user on the PI.
If you can’t ssh then mariushosting provides a recipe for running id via the Synology web portal.

Firstly, sk8rs_dad, thanks a lot for your response which I appreciate very much. I’ve spent many hours learning about pi and the various coding lines, and now It appears it will soon work - says from the Synology interface that it’s preparing to backup now.

One more niggling issue I cannot seem to shake and am not sure where to look to fix. My Pi-4 has four USB ports, two USB3 and two USB2. I have a thumb drive with the Pi software (the op system hard drive) in one USB 3 port and the external drive in the other USB3 port. Both devices (drives) are USB3 (blue inside). The external drive has its own power supply. That’s the setup.

Now, when I ssh into pi and do a sudo reboot now command, the external drive powers down and won’t turn back on when the pi reboots. If, however, I plug the external drive into one of the USB2 ports, then do a sudo reboot now, the external drive actually does not power down and boots back up / mounts properly. Also, if I physically unplug and replug the powered down external drive from the USB3 port after the pi has rebooted, the drive starts and mounts properly.

So for me it seems there’s a setting on that USB3 port which turns the external USB drive off somehow. I researched the web, though all responses assume my external drive is running from Pi power on the USB port (it’s not, it’s plugged into its own power supply).

Very happy for any tips, and anyway, it works now, so thanks a lot for your help!