Can't Login to Photos or Drive on iOS Phone

I’m unable to login to either of these apps on my iPhone 12 using my non-Admin login and QuickConnect ID (not the full URL). Oddly enough, I was able to login to the Synology Photos app using the newly created Admin login, but not my non-admin account.

I’ve check permissions in the Users setup on the NAS for all of my logins and all have permissions to the Photos and Drive apps. I also have my logins in a family group which also has permissions to these Synology apps (products). All logins also have permissions to my ‘family’ shared folder.

On my phone, I’ve checked Settings > Privacy > Local Network > Drive and Photos Mobile, and both are toggle on. (shouldn’t be an issue since the admin account logs in fine)

This seems like a permissions issue but I’m not able to locate it. Where else can I look for a resolution?

BTW, on my laptop I’m able to use my non-Admin account to login using the Drive desktop app and my QuickConnect ID with username / password.

Can you log in to the DSM desktop as a standard user and open the Photos app with the icon from the menu?

I normally use the Chrome browser on my desktop. But, as a test, I fired up Firefox, logged in using QuickConnect with my non admin login, and then clicked on the Photos icon and all worked fine.

Since that worked, I then tried using Safari as a browser on my iPhone, used the quick connect option again, and was able to login using that account. I got a message saying that DSM manager was only available to administrators (something like that) and then it let me continue. Once logged in, I was able to click on the Photos icon just fine.

Keep in mind both of those attempts were all on the same wifi network here at home.

So, it’ seems to me that it has something to do with the Synology ios apps.

Thanks for the reply. It shows that application permissions are fine. You mentioned that already, but this is the way to test that the server does what you want it to do.

Next, could you (as administrator) go to Control Panel > External Access > QuickConnect > Advanced? There is a setting that allows mobile apps via QuickConnect. Please check that it is enabled.

Yes, all the boxes are checked on the control panel > quick connect > advanced screen. Also, keep in mind that I’m able to login with the app on my phone as long as it’s the admin login. So that makes me think it’s a permissions issue with non-admin logins, but I can’t find anywhere in the user settings that’s not set to allow read/write.


Update. I was able to get the app to work. For some reason, the password pulled from my password manager must have been incorrect when auto filling the app login. Out of town this weekend and copied the password from my password manager and pasted it into the app login, and it worked.
Thanks for your help.

1 Like

Are you using 2FA? If you are, each login will require it’s own 2FA setup, e.g., Synology Admin & Synology User.