HELP! I'm tried everything I can find re: "the local device name is already in use error"

So everytime my WIn10 pc wakes up from sleep, I get this error message.


Not just that, but I get this error window for every instance of Explorer open with a connection to the NAS. And if I had a file from the NAS open, I’d get further error messages.

By the time I clear the error messages, the connection seems to be working again. But it’s driving me absolutely insane to have to close multiple error messages everytime my PC wakens from sleep.

A couple of things to note. The connection works perfectly fine otherwise. My main connection on this PC is a 10Gbe direct connection to the DS1621+. However, this error occurs even on a 1Gbe connection that is mapped through the NAS. Also, the error occurs even if I disconnect the 1Gbe connection that is connected via the switch (to provide internet access to the NAS).

I’ve tried disconnecting the mapping and remapping to different drive letters. I’ve reinstalled NIC drivers. I’ve remapped the connection via the Command Prompt.

Nothing seems to work. Since the connection works fine otherwise, I’ve just lived with the issue, but it’s driving me insane that I can’t seem to fix this.

Please provide any suggestions that might work. I’m dying here. :joy:

I know your pain - been there several times.

It might be that you have a specific SMB share that you want to access with 2 diffferent user accounts.

\nas01\photos with user JOHNDOE
\nas01\photos with user JANEDOE

Try cleaning your SMB credentials on the windows machine

display all active SMB mappings:
→ [windows] + [R] → [cmd] → [net use]
Copy and paste the SMB mappings into a text file for later

Delete all active SMB mappings:
→ [net use * /delete]

Reconnect the SMB drives
→ go the the text editor where pasted in the SMB mappings
→ rearrange the text blocks like this [net use P: \NAS01\Photo]
→ copy and paste the command into your terminal window and run it

If youwant to save the file as a batch file just use [save as] and save it with .bat instead of .txt
By double clicking the file you can map the drives also on other use profiles or computers.

1 Like

This is a windows glitch that I have seen a ton!

Let me know if @Stephan_Angele solution works!

Yes, and from what I’ve read it can be very stubborn and hard to fix. So far everything i have tried as failed.

I’m going to try everything I have done so far, including the ones @Stephan_Angele mentioned, one more time and I’ll report back.

Yes it a pain in the but … @Will if you come across a solution let us know …

I have similar annoying situation as well but I’m not trying to log in under two accounts. Unless windows is doing something strange, I suspect the credentials manager some how has got two accounts. Possibly due to my own doing…

I have had my set up for years access SMB shares from two windows (now 11) PC. Worked flawlessly for many years. And recently using my second computer again it started acting up. Did the usual clearing credentials manager, removing mounted / mapped shares which usual gets it working again Until the next reboot or so. We’ll see how long it works this time. Fortunately the laptop still behaving but really deterrent from working on my images in lightroom when this happens.

I use three mapped shares all using the same account… Well possibly what started all this was adding the 3rd share for my wife’s pictures and probably trying to set her up originally on a different account.

I never did figure this out, btw. I’ve basically been living with it. :laughing:

Windows likes to automatically assign low drive letters to physical devices. Is it possible that you’ve added a drive or removable device some time after the network drive was first mapped to E:?