I cannot manage to do port forwarding


I am new to Synology and to the SpaceRex YouTube channel. I saw the video about setting up your NAS remote access and I’m trying to use OpenVPN to access it.

My understanding is that I need to do port forwarding on my router to be able to use OpenVPN. I tried with the following set up but it does not work unfortunately… The port is still closed. Would you be able to tell what am I doing wrong?

Here is the OpenVPN settings and my router settings. So I tried to open the port 1194.

I guess the issue is linked to the other device I have between my router and the internet line. Basically I have another router (I guess) that takes the internet connection and transfers it to the router I configured via a LAN cable. @Will said that we have to set the middle router in a passthrough mode but I do not know how to do…

Just for information, the router I configured is the Tp-link AX3000 and the router connected directly to the fiber is the Nokia G-240G-E.

Appreciate your help

First things first. Make sure that port 1194 is open on your NAS and that there is a firewall rule on your NAS allowing traffic in. Every checkpoint (router & NAS) needs to have the port opened and a firwall rule to let traffic to pass. If it is then remove the Nokia and connect your TP-Link router WAN port directly to the internet and then see if the port is open to the internet. Make sure that your setup will otherwise work if the Nokia isn’t there. I don’t think the Nokia is a router. I think it only converts a copper connection to am optical fiber connection. I assume you already have internet connectivity.

Thank you for taking the time to reply to my problem :smile:

The thing is that I cannot connect the internet directly into the TP-Link because the cable is not the same…

The upper cable is the one giving me the internet and it is smaller than a normal LAN cable. Unless there are some adaptor I could buy online to solve this ?

Are you saying that from your wall that the jack is an optical jack and not a regular RJ45 ethernet jack?

I added some more stuff to my first reply. Re-read it please.

Regarding the opening of the port on my Synology NAS… I don’t think I it. I just activate the OpenVPN server in the “VPN Server” app of the NAS. I’ll try to search how to do this online unless you guys have a link to a tutorial :smile:

As for the firewall. I deactivated it so I don’t need to give special permissions.

You are right about the Nokia device. The internet cable is an optical cable. I guess the Nokia device works as an adaptor with a regular RJ45 cable as output.

I think I manage to find how to open the port on my Synology (cf. screenshot below). Please let me know if this is the right way to do because it still does not work… When I click “Test Connection”, it fails.

Quentin, I want you to remove the pics you posted and then obscure the External IP and obscure your DDNS host name. Repost after they have been obscured. You are giving out too much information. Once everything works it will be a matter of guessing your Username / PW to get into your NAS. There are hacker that have software that can systematically check.

Oh… ok thank you for telling me. Will be careful going forward.

The port forwarding rule on the NAS looks OK but that’s no guarantee that it’s connected. Did you use the “Set Up Router” button on the "Router Configuration " tab? To use it, first your router needs to have UPnP enabled for your LAN and after you click the button hopefully the NAS will recognize your router as compatible. It’s generally 100% better if the NAS and router make the connection themselves. If you let them do it the rule should look like this:

Ignore the 53804, yours should read 1194.

No I did not use the “Set Up Router” button because I could not see my router in the default list. To open the port I just tried to click on “Create” on the “Router Configuration” tab and it let me input the port so I assumed that my router and my NAS were already connected.

UPnP was disable so I just enabled it. Should I leave it enable all the time going forward?

The NAS recognized my router, good sign. But the port connection still failed…

How are you testing if your port(s) are open? There are several ways:


But be advised, it is possible that these sites cannot actually determine if your port(s) are open.

I checked your external IP that you accidentally posted using portchecker.co and port 1194, 80, 443 was not open. It looks like you have absolutely no ports open whatsoever. If you have internet access you must at least have ports 80 and 443 open. I’m thinking the problem lied between your NAS and the TP-Link router.

With UPnP enabled try to use the Set Up Router button again.

Once you got things working, only then should you disable UPnP. Lots of people say UPnP is bad but when you are setting things up for the first time it can be very helpful in making the initial connections.

See if your router has created its own firewall rule for port 1194. Not a firewall rule you make, a firewall rule it made with your NAS.

You may need to refer to your TP-Link user manual or check this website on how to port forward for your model router. https://portforward.com/

I use the second website you listed to check my open ports… But same results as you, all the ports are shown as closed.

No firewall rules on the Synology or on the router.

Ok, I’ll dig into the port forwarding of my router. Good to know that (at least) the synology settings are now properly set up). Thank you for your help so far, appreciate it!

Just to be sure… Regarding the port forwarding on my router, I should use the internal static IP I set up only, am I right?

No need of any external IP?

Your router firewall is enabled. Answer me this. Generally, you need to create an “Allow” rule to allow a port to be opened to the internet. Can you create an allow rule on your router to let UDP port 1194 through to