LR cat Mac and PC can't find network folder location

Hi all, I have been following Wills youtube channel since some time, and finally decided to move to a Synology DS1821+.
I am a professional photographer and have a big WIN11 desktop with internal HDD’s which stores all my photos, which is pretty darn fast. However, I also have a fully spec’d MBP M1 Max, which is just faster, so I am often editing on my MBP. Since I was constantly working around, having to open multiple LR catalogs, I wanted something better/easier. I have been working with LR since the beginning in 2006 and I know it like the back of my hand and don’t make rookie mistakes like moving folders outside of LR,…

I have two master catalogs, one personal files and another work files, all images in RAW, one containing around 80k images, the other around 125k. So I followed the channel completely and set up everything like I should (or at least I think so), from my desktop. Synology drive is syncing my catalog files and support files from pc to Syno to MBP and vice versa, which works great. After copying all raws onto the Syno (which took a few days), I then opened LR cat on my PC, and updated the folder location to the synology. I made sure to point it to the sharename, not to a drive letter (so \DrBobke-Syno\Fotografie), through network. All is working fine, no issues there. I then built smart previews for all images in the master catalogs (which took a long time), all good!

I let some time and made sure the catalogs were updated on the Syno Drive and also on my MBP and I opened the catalog there, so far so good. However, I am getting the “?” now for the drive folder and although I can open the various folders, I can’t see any images inside of it, not even the smart previews I have made.

See attached screenshot of my MacBook in LR. Folder location is \DrBobke-Syno\Fotografie, which should be right, as far as I can see?

I have checked and verified that I do have connection (even via Cat5e) with the Synology and in Finder, the connection is working. I don’t want to update the folder location of the images on my Mac (in LR), as I will have to redo it when I open the catalog on my PC and again on my Mac and then I keep going.

There must be something I am not doing right I think. A friend of mine who is a network expert, found that disabling the v6 on the Syno could help, but sadly it didn’t.
I am pretty versed myself around networks (even built my own unraid server), but this is a little too complex to troubleshoot and I am not really a Mac fanboy, except that the MBP is so darn fast! So all Mac settings I don’t really know too much about.

The reason for setting all of this up with the Synology, is getting everything to work, so I can work from pretty much everywhere in the house, or on location (I am often abroad for a few weeks at a time and would like to be able to get to everything).

Any help is greatly appreciated!
Best regards,


DrBobke, you said

and updated the folder location to the synology. I made sure to point it to the sharename, not to a drive letter
How did you do this?
The path you showed does not have one extra back-slash
yours - \DrBobke-Syno\Fotografie
expected - \\DrBobke-Syno\Fotografie

Hi ZippedPhotos.

Thanks a lot for your message, I really appreciate the help.
So what I did, was take my master ‘work’ catalog on my WIN11 pc and made a copy of it and called it the same, with “Syno” in the name. I then updated the folder location inside lightroom to the folder on the Synology, which worked. It found all the images, no issues. (I did this through navigating to “Network”, selecting my Synology NAS, going into the ‘Fotografie’ folder and then work).
I think I might have mistyped, in the screenshot I attached, it is “\DrBobke-Syn\Fotografie”

Synology drives synchronizes all catalog files (incl smart previews etc) to my MacBook. I can open the catalog on my MBP just fine and all the changes I have made (added a few shoots,…) I can see.
However, the original RAWs and the smart previews are missing. I can’t relink them on my MBP. When I go into “Find missing folders”, I can go in and see my Synology and navigate to the right folder. However, I am getting an error. This is very strange, as I have no issues in going there through LR, nor via finder, all works great.


So I am guessing there must be some “misnaming” or something going on with the share/network name. I already disabled AFP on the synology, but I can’t find the setting on my MBP anywhere since they updated the systempreferences view. I have googled about everywhere, but simply cannot find it (and I spent at least 3 hours searching for it). But since it is disabled on the Syno, it shouldn’t connect to that anyway and should go through smb share. (At the start, I was connected through AFP to my Synology, I changed it later to SMB, so maybe that might still be active somewhere)
Another thing I don’t really understand, in the new LR Cat “Syno”, I have made the smart previews for all images, which are also synched using syno drive. I have done this, so even when I am travelling or on the road, I would still be able to view and edit all the images in the master catalogs. However, these also do not show up on my MBP.

I am quite puzzled to say the least.

That was my guess. I wrote a long question based on my assumption and then deleted it.

Just to clarify your setup.

NAS. Internal network hostname DrBobke-Syno. I guess to use outside your home network you will update the file hosts on Windows and MacOS.
Shared folder \\DrBobke-Syno\Fotografie
Synology Drive enables Fotografie as a Team Folder.
MacOS and Windows have installed Synology Drive Client.

I guess, you decided to make Synology Drive Client to do the sync. If so, this is where the problem starts (not your fault but Microsoft’s)

I know how the path on Windows looks. If you updated the catalog on Windows, then MacOS will not be able to read it.
I do not have MacOS handy, I guess the path on MacOS will look
~/Library/CloudStorage/SynologyDrive/Fotografie where ~ is /Users/<you>

I see the only option is to use the network path directly, but in this case, you will always work on network files, not on fast local disk copies.

I’m not an expert in Adobe products (I used LS 15 years ago though), but can you have two separate catalogs which will update/refresh from mounted OS-specific locations?

I’m waiting for 20+ years when Microsoft will fix:

  • backslashes to slashes
  • named disks (just have root /)
  • CRLF to LF
1 Like

I did find a solution to this in the meantime - it is a workaround, but it works for now. It’s a known issue for sharing catalogs between Mac and Win. This means I still need to relink the folder (raws on the NAS) inside LR every time I switch computer to Mac and vice versa, which is very stupid. However, it does work for now.

Here is the solution :

So I have found in my experience that Adobe is really trying its best to make NAS units unusable with their software. Its incredibly often that they will push out an update for photoshop, Lightroom, or something else that just breaks NAS compatibility.

I personally think they are doing it on purpose, driving people to using adobe cloud. SMB has been around since the 90’s. its really not that hard…

@DrBobke, that is very hard for me to accept that as a workaround, more like shaman dances and magic squats. If you make me do this, my PC will be replaced with MacMini very fast.

@Will, as I mentioned - Microsoft is the guilty one. However, I believe, if Adobe just implements support for relative paths and enforces usage of normal slashes inside the catalog file it will work everywhere.
Windows accepts normal slashes in the commands, therefore the path
./Fotografie/innerDir/my_nice.raw is accessible on Windows and MacOS right now.

@Will, you referred to SMB, but that means using the network drive. Did I get it right?

I was thinking along the same lines, Ivan… That is why I went the route through the network on my WIN11, as I (wrongly) thought that assigning a drive letter to the network share, would cause problems.

However, the opposite is true. When you assign a drive letter to the NAS (in my case the share “Fotografie”), I can alter the path when I am on my Macbook to the network ‘Synology/Fotografie’ folder. When I am done editing on my Mac, I can open the LR cat on my PC, refind the missing folders and assign them back to the network share drive letter I created.

It’s definitely a pain in the *$^, but at least I can see my photos. I was amazed at the fact, that even though I made smart previews for all images, when it is not assigned correctly, they won’t show up either. There goes the whole reason why I bought the Synology in the first place, to be able to edit on the go. However, I didn’t test this yet outside of my home network. I assume I’ll have to be diligent in updating the folder path inside LR on my MBP before I leave the house every time…

If anyone has any idea how this could be fixed, I’m all ears and willing to try. I surely can’t be the only person with a NAS and a pc and a Mac?

I will not sleep until I understand your full set up. :slight_smile:

PC WIN11 - no Synology Drive Client
PC WIN11 - the network path \\DrBobke-Syno\Fotografie is mounted to a letter (let’s call it F:)
PC WIN11 - LR opens the catalog file from F:\ and indexes all the files.
Whenever you touch a file you read-write directly on NAS F:\<directory>\file.raw\\DrBobke-Syno\Fotografie\<directory>\file.raw

@DrBobke , with your latest response I suspect there is no Synology Drive Client at all.
MacOS - Synology Drive Client.
… the thought was lost…

Do you know what I would do if I have that problem?

To have two catalogs and write a tool that sync them one way on LR (Win/Mac) startup.

(I will check my wife’s LR catalog on Win tonight).

Hi Ivan,

PC Win 11 - there is a Synology drive client on, which 2 way syncs all LR cats (and support files like smart previews) to the Synology (and syncs those to a local folder on my MBP using Synology drive client (and vice versa)).
PC WIN11 - correct (actually mounted to Z:)
PC WIN11 - No, the catalog file of LR can never be on a network share, it has to be locally accessible, which is on my C drive (a fast M.2 Nvme drive). The raws are housed on the Synology, in share Z: (\DrBobke-Syno\Fotografie)

Having multiple catalogs - I’m not sure I understand this. I do have Synology Drive client syncing the LR cats and everything in two directions. However, the raw files are on the synology and that is where the issue lies. Somehow, if I relink the raws on my WIN11 machine, they are unreachable from my Mac, until I relink the photos in LR on my Mac to network \DrBobke-Syno\Fotografie.
When I had it first setup, I deliberately browsed through network on WIN11 to \DrBobke-Syno\Fotografie, so there is no drive letter attached, as I thought that would be an issue. However, in doing that, LR locks up on my Mac giving the error “Invalid path” and I can’t redirect it, as it keeps giving me this error.
When I then open the LR cat on my WIN11 pc, and mount \DrBobke-Syno\Fotografie as a network drive (Z:), close the cat, wait for the sync, then I can link the raws on my Mac to the share \DrBobke-Syno\Fotografie.
However, until I have linked them, I can’t open the folders, nor can I see all the smart previews I have built. This renders the whole setup basically useless, as I wanted to use this to edit pictures (as smart previews) when I am on the road with no connection.

I hope this clarifies?

Thanks a lot for your efforts in thinking along with me! :slight_smile:

Thank you @DrBobke for the clarification.

I thought the all-purpose was to work on the images efficiently, but it seems the primary goal is to have the catalog.

I think, now I understood everything. The catalog file is a binary file with a lot of information. Until Microsoft addresses the two problems I mentioned earlier we all have to suffer.

As the catalog file contains paths I would never sync it as a file. But, I would like to sync its data.

I did not do any research (looking for a job now applying for positions 7 hours a day).

I’ve just grabbed one file for analysis. Good news is Adobe did not reinvent the wheel and use SQLite to store catalog data.

You can use this browser to open your catalog file (just make a copy of it or do not update through the browser).

Bad news is there are 119 tables. I guess, there is documentation for this or many people already built something. If not, I have to build that daemon/service/tool which will sync the catalog. This is a good workaround, but you must have two catalogs - Win11 and MacOS. The tool in the middle will make sure all deltas are the same and do not collide. There might be some difficulties in how IDs are created (there are numeric IDs that could be as max+1 in the current file, which means if the catalog is being updated from two LRs at the same the collision can occur).
Maybe, it could be solved just by modifying or creation a trigger, which will update path to reachable on both OS’s.

Why do I have to build (or find a solution) sooner or later my wife will ask the same question. :slight_smile:

Once I find a job, I will do proper research (not a brute-force dissection) and will suggest a solution.

The table AgLibraryRootFolder contains the path. The column names suggest me that Adobe thought about this problem already.

If you want to play, I suggest doing:

  • close LRs
  • copy/backup the catalog file
  • open the catalog file in that tool
  • modify the table AgLibraryRootFolder by setting relativePathFromCatalog to ./ and absolutePath to null.
  • let Synology Drive Client to sync
  • Open in MacOS then on WIN11

Let’s say my wife’s catalog file is D:\LightRoom\MyCatalogs\Lightroom Catalog.lrcat
This is how updated records will look

Unfortunately, the column absolutePath has a not-null constraints, but I believe Adobe made it right (I even think now, that it could be done in LR), and if a relative path is provided it trumps the absolute one. If not, there is a big room to play.

As I thought, Adobe is not stubborn and already changed back-slashes to slashes to have fewer problems in the future.

Hi Ivan @ZippedPhotos, thanks a lot for your detailed message and my apologies in the delay in getting back to you. I was unexpectedly out for several days and am just getting back now…
Hopefully your jobhunt goes well and you can start somewhere soon!

My goal is indeed having the catalog and I want to keep it as lean, efficient and straightforward as possible…
I got the catalog to work, also outside my home network, it took some tinkering, but finally sorted it out. I did notice a very significant slowdown in performance of the catalog, although the cat is on my internal SSD, so are the smart previews (and in the settings of LR, the tick mark is on to use smart previews for editing). @Will - any idea why it was this slow to use?

While I want to keep 1 master work catalog and 1 master private catalog to use for both my pc and my Mac, not everything goes as planned. I am often greeted on my Mac with a message that my LR cat is corrupted and needs to be fixed. I never had this issue before. Moreover, and this is the weird part, it also happens when I shut down LR on my Mac and open the cat a few minutes, hours or days later on my Mac (thus no opening on my other machine / WIN11).
The smart previews work outside my home network and on the home network, and although I have a 2 TB internal SSD in my Mac, I have noticed that just one of the master catalogs’ smart previews is almost 100 GB in size. This means Syno drive (synching a few catalogs), is over 256GB. If I interpret what you are writing above correctly, that means I will have 2 versions of everything, which means over 512GB for just LR cats etc? I do still have some free space on my Mac (I only use it for editing pictures and storage of RAWS when I’m on the road), but I don’t want to sync multiple things multiple times.

Thanks a lot for all your efforts and writing it all out. I am not one to be tinkering with tables and paths and stuff. I am worried it would break too easily and I wouldn’t be able to work anymore…

Best regards,