Macbook Finder has stopped connecting to NAS

Hello, Having set up my NAS a few months ago including being able to access my NAS files/photos from Finder, that function has now stopped working. I can access the NAS via DSM (no problems there) but I cannot connect to my NAS from Finder.

I’ve included 2 pix to show what I am seeing:

Macbook finder - not connecting to NAS
When I open Finder, see the ‘Connecting…’?
That’s where it NORMALLY shows ’Not connected’ and then NORMALLY I click ‘Connect As…’ (and log in) and I would be connected to my NAS. But this weird ‘Connecting…’ has started from out of the blue.

When I click ‘Connect As…’ I get this message.
Macbook finder - error message

I have:
—restarted my macbook
—shutdown and restarted my macbook (and all updates are installed)
—restarted my NAS via DSM
—shutdown and restarted my NAS via DSM
but nothing seems to work.

Today is not the first day this has happened - it has been going on for about 2 weeks - I just hoped I could fix it myself, but nah…

Any problem-solving suggestions welcomed.

What version of DSM are your running?

It wouldn’t hurt to go to Control Panel → File Services → SMB Advanced Settings and hit ‘Clear SMB cache’

Well that was a dumb suggestion. Restarting the NAS would have cleared the SMB cache.

Thanks for such a quick response :clap:

My version of DSM is 7.1.1-42962

I did as you suggested (‘cos I’m not techie so I just want to try any fix) and then restarted both macbook and NAS, and yes it seemed to work but I am not getting too excited about it because after numerous shutdowns and restarts of both macbook and NAS over the past few weeks, it would sometimes be fixed.
Now that it’s working I just want to use it, and the next time I log into it, I’ll let you know how it goes.
Fingers and all other digits are crossed :crossed_fingers:

As a continuation on from my previous comment…
The connection to the NAS has now been lost after working for about an hour. When I restarted my macbook, it didn’t fix it, nor did restarting the NAS.
I seem to be back at the start - where Finder is not connecting to my NAS.
However I can still use Synology Drive that I’ve set up in Finder, it’s the NAS that is not connecting.

Any suggestions for fixing?

What MacOS are you using?

You are using SMB to communicate with the MacBook (not AFP)?

Probably you are.

Since sometimes you can use DSM through the browser but not through a Finder share, the problem has something to do with SMB

Are you using the same Synology user account when you log on in the browser and over the Finder share?

Is that an administrator account?

You can use different accounts, but if one is an administrator account and the other a more restricted account there could be permissions problems.

My answers to your questions:

Does that help at all.

Control Panel → File Services

The first screen will have ‘Enable SMB service’ checked if you’re using SMB.

So you can put the IP address of your NAS in the browser you can log on to it, but if do a ‘go → network’ on the Mac, the server name of your NAS doesn’t show up?

SOLVEDSOLVEDSOLVED**: You are not going to believe this but the solution is

:drum: drumroll please

…disable SMB then re-enable it.
DSM>Control Panel> File Services>SMB Settings>uncheck SMB, click apply then check SMB and click apply. Yessir, the old ’switch it off and switch it on’ routine.

I found the solution in a Reddit post and it was exactly as I experienced. But the amazing thing is, is the other person who uses the NAS (on the same network) has a perfectly working NAS/Finder set up, no problems connecting at all - and I did the setup!

(I deleted my 2 previous posts in this thread - because they didn’t add any value.
I am trying to be a better forum participant; not so many little answers, more in-depth answers - thanks for the tip @Spacerex)

And many thanks to @Pete who helped me frame the correct question so I could hunt for an answer.

Just an update.
Even though I said that the problem was solved - it wasn’t.
It was intermittent; just as I thought it was fixed, the wheels fell off and it wasn’t fixed.
I put a request into Synology along with the NAS log file and their reply said …

…connect the NAS to the Macbook with an ethernet cable…

And my friends, this DID work.
They also said to disable IPv6 - not sure what happens when you do that so am awaiting their reply.

1 Like

There is an on-going MacOS problem.

(Google Mac Venture SMB)

With the recent update to Venture 13.4 I had to re-do this fix.

Also had to do it for the previous version.

System-Settings → General → Sharing → Turn File Sharing OFF

Shut down the Mac

Restart the Mac

System-Settings → General ->Sharing → Turn File Sharing ON

Before doing this I could not connect to my MacBook over SMB from my Linux Machine or from my iPhone.

After this fix was able to.

Hopefully it lasts until the next MacOS update.

After connecting by an ethernet cable and, voila - I can see my NAS in Finder again.
Even when I disconnected the cable I could still see the NAS each time I logged in.
The ethernet cable connection sort of ‘flipped a switch’ so it worked each time - when I wasn’t remote. At home the NAS works fine but when I have been remote and return home I have to do the ethernet cable attachment and then all is working fine.

This time when I returned home, I tried this fix by @Pete

System-Settings → General → Sharing → Turn File Sharing OFF

Shut down the Mac

Restart the Mac

System-Settings → General ->Sharing → Turn File Sharing ON

But it didn’t work for me.
So I am back to using the ethernet cable connection.

Thank you this worked for me. My file sharing was turned off.