SMBv3 Multichannel CANNOT increase speed with 1x 2.5GbE with 2x 1GbE connections

Trying to use a 2.5GbE laptop, to get SMB Multichannel does not appear to work

So I was doing some testing with SMB multichannel, and was attempting to recreate Synology’s setup here:

From their blog post here. This clearly shows being able to use 1x client NIC to still get SMB multichannel goodness, however their knowledge base article here appears to disagree.

My testing:

So I attempted to do exactly that (well 2x 1GbE rather than 4x, but close enough).

What I did:

  • Plugged 2x 1GbE connections into a 10GbE Switch from NAS
  • Plugged 1x 2.5 GbE Connection from switch into laptop (macOS)
  • Enabled SMB Multichannel on both client and server


Here are is the output of smbutil multichannel -a

As you can clearly see, macOS sees the 2x 1GbE connections on the server, however is still negotiating with only 1x stream, due to the fact that there is only 1 NIC on the client. The end result is that even though the setup could easily have 2 GbE connection, it is not negotiating to that. From this image:

it does look like 1 NIC can support 2x TCP streams to different client NICs so this could work. I am not sure if this is a macOS issue or a windows issue.

Could someone on windows try this and let me know?

Wouldn’t shock me if this were a macOS issue, as SMB multichannel is widely reported to be flaky on a Mac (and is in my experience as well).

From what I have read from my YouTube comments I think that you may be correct. Windows seems to be able to!

1 Like

One thing I’ve seen is that disconnecting and reconnecting SMB shares often fixes the problem (like with my recurring problem of it trying to multichannel with wifi as one of the channels). Occasionally even a reboot is needed. So it’s possible it does work, but a macOS bug seems most likely in your case.

Intersting! For me I have not had really much of any issues from a connection standpoint, though I have never tried to use wifi for one of the channels.

I never want to use it as a channel, but when I go from SMB over only a wifi connection to connecting to my monitor/USB hub, it keeps the wifi connection and adds one of the USB ethernet connections to create the multichannel. Apple does have documentation to “favor wired” but that kills my networking completely. I assume it’s something that changed in Ventura, so it’s just a good reminder any of this is subject to change for better or worse in Sonoma too.

ah intersting. For me I always just turn my wifi off whenever I connect wired ethernet to force everything to just use wired

1 Like

I can’t try this on Windows like you asked, but from my reading on switches, a 10Gb switch doesn’t necessarily support lower multigig speeds, unless it’s a more recently built multigig switch. So i wonder what kind of switch you used in your test and if you could get a better result with a different one?

Also, im looking for a single-cable solution for a laptop workstation to provide both data at 2.5Gb or better and power via USB C PD 50watts or better. Theoretically / hypothetically this could be adapted from a multigig PoE switch. However, the only adapters Ive seen so far on the market are 1Gbe and it’s ambiguous whether the data is really on the same USB C cable connector as the power delivery. Something that should exists!

Hi, this is exactly my setup on Windows and it works.

2x1Gbps on my 923+ connected to a 10Gbps switch.
On this switch is connected my Windows PC with a 2.5Gbps network interface.

I can copy data from my NAS at ~210MB/s.

1 Like

Great to know! Guess it’s a macOS implementation bug

1 Like

Definitely worth checking to see if Sonoma fixes it. If not, it’s probably worth mentioning to Apple on their feedback page.

I can’t seem to get it to work with Windows 10. I have a laptop with a 2.5 ethernet connected to a switch with a one 2.5 and four 1Gbps connectors. The laptop is connected to the 2.5 connector on the switch. I have 2 cables running from two 1 Gbps connectors to two 1 Gbsp connectors on a synology 1522+.

I can only get 90-100 MB/s transfer speed total. If I look at the Synology Resource Monitor it looks like both LANs are receiving about 50 MB/sec each.

I checked to see if multichannel was enabled in powershell on the laptop with
Get-SmbClientConfiguration | Select EnableMultichannel
and it returned “true”

Any ideas? I assume if I add the 10 Gbps upgrade card to the 1522 and connect the laptop directly to the the 1522 I should be able to get 2.5 Gbsp speed. I have a lot of data to upload to the NAS so it would be worth it if I can’t get multichannel to work.