Synology HTTPS protocol to access Docker container

Hello all,

First time poster on the forum here. To listen to my audiobooks I use a docker container as a library for all the ones I have bought over the years. In order to access the container in a more secure way I would like to access it over HTTPS with a reverse proxy. I had it up and running a while back but it doesn’t seem to work anymore…

Please see attached the screenshots of the setup, which when I type the https://certificateforproxy in the search bar it fails to reach the docker container.

Thank you for any attempts in helping to get it up and running again


That destination hostname looks really weird, 100.x IP’s are meant to be reserved for CGNAT, but tailscale uses them.

You should just replace that destination hostname with localhost if you are hosting it on the NAS

Hi Will, thanks for your reply.

It is because I am running Tailscale to use the NAS remotely as I live in a different country than the place my NAS is running from.

I did try with localhost before posting this thread but there is no difference…

So the reverse proxy stuff all is relative to the actual NAS. Does resolve to the IP of the NAS? Where does it go when you type it in?

I changed it to the IP of the NAS to see if that worked but no luck again… I actually remember that I used to have the IP of the tailscale link for the reverse proxy, and it worked back then. I think I am out of ideas on what could be going on, maybe just an error after an update of the docker container

Basically you need to make sure that that link actually hits the NAS, however you are connecting, tailscale IP should work if you are going through that tunnel. Then the proxy redirects it from DSM to the docker port