Media server / DLNA not showing content

I have run in to an issue trying to play my images stored on our Synology over DLNA devices. I recently upgraded to a new Nas device and migrated all my content over. Everything appears to be working correctly and indexed. But I have not been able to view any of my images or videos over DLNA. Photo works great and all other services are working. It hasn’t been a major concern as photos works but would be nice to be able to display images through the TV again.

Media server is enabled and I have reindexed my media files. The menu(s) do show up but no content is found. I am sure I am missing something basic, permission, access?. I have selected the option to make video station files available through DLN & those videos do appear. But only from the video station menu.

Every thing UpToDate, only step I haven’t performed yes is to uninstall & reinstall the media server & codec extension.

ANy Help would be appreciated

That surely is the expected and correct behaviour.
I use a Synology DS220j NAS and have many videos stored in the video share in File Station. These are properly available to view on my smart TV through the decoder attached to it accessed via the Ethernet network. I posted some content about this set up in another topic.

My previous NAS was 220J, streaming worked great with it. Just when I upgraded to the " + " I ran into issues. Non of the images, videos or any content from the Media server appear. Just videos from the video station.

Do you have link to the topic or title name?

sure - DS220j interaction with Orange (France) TV Decoder UHD 4K
The interesting thing is that some content on the NAS when accessed from my Linux PC complains about absence of codecs but they run perfectly well when accessed from the decoder/TV which suggests issues with the PC OS perhaps which don’t feature with the decoder/TV side of things, perhaps…

I am posting the solution that eventually Synology support provided. As I have read in various forum I’m not the only one to run into this issue.

After taking a deep dive into the workings of the media server and cracking the hood on the database, turns out my media server database was not getting populated. likley related to the security changes & privileges changes introduced in 7.x

Eventually the Synology Dev support team had to drop & recreate the media server’s tables. Once that was done all worker.

There was a post in the forum somewhere about a procedure to drop tables & reboot. I advice agiast it as sledge hammer approach never goes well. THe synology guys will have the proper scripts to recreate all their tables…